CVE-2023-22522 - RCE Vulnerability In Confluence Data Center and Confluence Server

Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.

SummaryCVE-2023-22522 - RCE Vulnerability in Confluence Data Center and Server
Advisory Release DateTue, Dec 05 2023 21:00 PST
Products
  • Confluence Data Center
  • Confluence Server
CVE IDCVE-2023-22522
Related Jira Ticket(s)



Summary of Vulnerability

This Template Injection vulnerability allows an authenticated attacker, including one with anonymous access, to inject unsafe user input into a Confluence page. Using this approach, an attacker is able to achieve RCE on an affected instance. Confluence Data Center and Server versions as listed below are at risk and require immediate attention. See “What You Need to Do” for detailed instructions.

Severity

Atlassian rates the severity level of this vulnerability as critical (9.0 with the following vector CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H) per our internal assessment.
This is our assessment, and you should evaluate its applicability to your own IT environment.

Affected Versions

This RCE (Remote Code Execution) vulnerability affects all versions including and after 4.0.0 of Confluence Data Center and Server. Atlassian recommends patching to the latest version or a fixed LTS version.

ProductAffected Versions
Confluence Data Center and Server
  • 4.x.x

  • 5.x.x

  • 6.x.x

  • 7.x.x

  • 8.0.x

  • 8.1.x

  • 8.2.x

  • 8.3.x

  • 8.4.0

  • 8.4.1

  • 8.4.2

  • 8.4.3

  • 8.4.4

  • 8.5.0

  • 8.5.1

  • 8.5.2

  • 8.5.3

Confluence Data Center
  • 8.6.0

  • 8.6.1

What You Need To Do

Immediately patch to a fixed version

Atlassian recommends that you patch each of your affected installations to the latest version or one of the listed fixed versions below.

ProductFixed Versions
Confluence Data Center and Server
  • 7.19.17 (LTS)

  • 8.4.5

  • 8.5.4 (LTS)

Confluence Data Center
  • 8.6.2 or later (Data Center Only)

  • 8.7.1 or later (Data Center Only)

Apply temporary mitigations if unable to patch

There is no current mitigation, however we recommend:

Note: Before restoring your instance to the public internet you must apply the latest fix version.


Frequently Asked Questions (FAQ)

More details can be found on the Frequently Asked Questions (FAQ) page.

Support

If you did not receive an email for this advisory, and you wish to receive such emails in the future go to https://my.atlassian.com/email and subscribe to Tech Alerts emails. If you have questions or concerns regarding this advisory, please raise a support request at https://support.atlassian.com/contact/#/.

References

Security Bug Fix PolicyAs per our new policy critical security bug fixes will be back ported. We will release new maintenance releases for the versions covered by the policy instead of binary patches.
Binary patches are no longer released.
Security Levels for Security IssuesAtlassian security advisories include a severity level and a CVE identifier. This severity level is based on our self-calculated CVSS score for each specific vulnerability. CVSS is an industry standard vulnerability metric. You can also learn more about CVSS at FIRST.org.
End of Life PolicyOur end of life policy varies for different products. Please refer to our EOL Policy for details.
Last modified on Dec 19, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.