Editor Does Not Work Properly

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

The problem can occur in either the page editor or comment editor. The editor does not work as expected. For example:

  • Bottom bar of the page editor disappears
  • Page editor does not show the content
  • Drafts are not saved
  • Comment editor shows an error: "Error loading the comment editor. Timeout while waiting for the editor resources to load"

The symptoms can vary. These are just some of the examples that you may encounter. 

Cause

Problems with the editor can be due to one of the following reasons:

  • Interference from a third-party plugin
  • Confluence JIRA Plugin is disabled
  • Customisations

Resolution

In order to fix this issue, please try to apply one of the following resolutions:

  • Enable plugin safe mode to temporarily disable third-party plugins, and check the editor. If the problems with the editor go away, this points to interference from a third-party plugin. You can then enable your plugins one-by-one to see which one is the culprit.
  • Ensure that the Confluence JIRA Plugin is enabled, because it is needed in order for the editor to work properly. The Confluence JIRA Plugin may be disabled during start up due to timeout

  • Ensure that the Atlassian TinyMCE Plugin is enabled, as explained in this KB
  • Ensure that the Atlassian Editor Plugin is enabled. This plugin may also be disabled during start up due to timeout, and this plugin must also be enabled in order for the editor to work properly. Increase plugin timeout value to prevent this from happening again. See Plugins are disabled at startup and various timeout errors appear in the logs after startup for more information.
  • Clear all customisations
Last modified on Dec 7, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.