You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 14 Next »

Symptoms

A user that has been deactivated in the past cannot be brought back to life. Even if assigned to the right groups with confluence access.

Note that this applies only to the older mechanism for user deactivation. In newer versions of Confluence, users are removed by removing them from groups with can-use permission, as described in Removing a User.

Cause

In older versions of Confluence users have been deactivated by inserting a row into table os_propertyentry with entity_id = theUserId AND entity_key=confluence.user.deactivated
This entry is still evaluated but there is no mechanism in newer version to remove this from the DB.

Resolution

  1. Backup Confluence
  2. Stop Confluence
  3. Find the user id (=theUserId) of the particular user in table users
  4. Run the following SQL query to identify the row that contains the 'deactivated' information. The entity_name column should have an entry like 'LOC_username':
    select *  from OS_PROPERTYENTRY WHERE entity_id = theUserId AND entity_key="confluence.user.deactivated";
  5. Delete this row from the table
  6. Restart Confluence.

Additional Information

Severity

Medium

Regular Expression

(remove|restore).*deactivated user

Article ID

CONFKB288655164


Unknown macro: {htmlcomment}

http://support.atlassian.com/browse/CSP-17384

  • No labels