Cannot create Application Link: There doesn't seem to be a running <product> server <version> or later at this URL

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Symptoms

When attempting to form an Application Link between two Atlassian products that reside on the same server, JIRA reports that There doesn't seem to be a running <product> server <version> or later at this URL despite the confirmed presence of a server at that location.

Diagnosis

Typically, this only occurs when both of the applications are on the same machine, but can occur any time there's ambiguity about the FQDN (fully qualified domain name) of either the target or the source server.

Cause

This is caused by the server's operating system being unable to communicate between the two servers due to naming ambiguity.

Resolution

  • Adjust your hosts file to declare the FQDN of the partner server to an IP address
    • Example: If your JIRA and your Confluence are both on tracking.example.com and that has an IP address of 192.168.0.45, put the following in your hosts file:

      	192.168.0.45	tracking.example.com
    • If your JIRA is at tracking.example.com and IP 192.168.0.45 and your Confluence is at wiki.example.com and 192.168.0.54, put the following in your hosts file:

      	192.168.0.45	tracking.example.com
      	192.168.0.54	wiki.example.com

      (info) More information about the hosts file including a list of common locations for popular operating systems can be found at the Wikipedia article on the hosts file.

       

Last modified on Feb 26, 2016

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