Unable to Create or Edit Users and Groups

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

  1. When trying to create or edit users and groups, the links to perform these actions are not available.
  2. When trying to reset a user's password, the option is not available

Diagnosis

  • Check the Jira application logs in the fileatlassian-jira.log. If the following appear in the logs during the start up, then Root Cause 1 might be relevant:

    jira.option.user.externalmanagement           : true
    
  • If the Jira application is configured with External LDAP or Crowd Directories, then Root Cause 2 might be relevant
  • If the issue started to happen after importing data from a Jira Cloud instance to a Jira Server/Data Center instance, then Root Cause 3 might be relevant

Cause

Root Cause 1

The External User Management option within General Configurations is set to ON

Root Cause 2

Jira is setup to use LDAP or Crowd for user management

Root Cause 3

A backup coming from Jira Cloud was imported into the the Jira Server/Data Center application, and something went wrong during the import, making the DB table cwd_directory_operation empty, and preventing Jira Admin Users from creating/editing any user and group.

(info) For more information about this Root Cause, please refer to the KB article Some user management operations are not available in Jira Server/DC after restoring a Cloud backup.

Resolution

For Root Cause 1

Set External User Management option within General Configurations to OFF

For Root Cause 2

Manage groups in the external user management system that has been integrated with Jira.

For Root Cause 3

For the resolution steps, please refer to the KB article Some user management operations are not available in Jira Server/DC after restoring a Cloud backup.

















Last modified on Apr 23, 2024

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