Unable To Create Branch

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Users are unable to create a branch and are receiving the following error message.

  • Creating a branch on the UI:

    We couldn't create a branch. 
    If this keeps happening, contact support.
  • creating a branch from the command line:

    remote: error: cannot update the ref 'refs/heads/<branch_name>': there are still logs under './logs/refs/heads/<branch_name>'

Cause

1. This behavior can occur if a branch with the same name already exists.

2. This behavior can also exist if there is a file or folder with the same name in the refs directory on the remote server.

Solution

Please ensure that there are no existing branches or prefixes with the same name that you are trying to create. To confirm this, you can access the branches page on the Bitbucket UI. To do this, go to the repository in question on Bitbucket UI, and look for the branches option on the left panel, as shown in the screenshot below.

If a branch with the same name already exists, delete it or create a new one with a different name.

If the repository does not have a branch with the same name, please contact Bitbucket Cloud support and create a support ticket to investigate the issue on the remote server.

Last modified on Mar 5, 2024

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