Attachments no longer open in browser and users are instead prompted to download the files

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Symptoms

On Confluence 5.1 and above, attachments files no longer open in the browser itself and users are being prompted for download.

Cause

The current behavior (Confluence not allowing attachments to be opened in the browser) is a side effect of a security improvement added to the product. As attachments can be "active content", the behavior in Confluence will not be reverted.

Workaround

For Self-Hosted Instances:

1. Click on cog at the Confluence header and choose "Confluence Admin"
2. Under "Users & Security" choose "Security Configuration".
3. Click any of the "Edit" buttons on the page and find the "Attachment Download Security Policy" section.
4. Select the "Insecure: Display all attachments inline" option and click "Save".

Instead of that, you can also use the Atlassian Companion for a more modern and streamlined experience if you are using Microsoft Office documents.


For Cloud Instances:

Please create a Support ticket at http://support.atlassian.com requesting the change to be done in your instance.


Last modified on Mar 21, 2024

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