Unable to push user from the Identity Provider through user provisioning with Atlassian Access
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Unable to push user email change from the Identity Provider into the Atlassian organization with Atlassian Guard.
Environment
Atlassian Cloud products
Atlassian Guard
Diagnosis
1
Resource [USER]: with email[name@domain.com] already exists.
Cause
This happens when an account is provisioned with emailA@domain.com from the Identity Provider and later the email is changed within the Identity Provider to emailB@domain.com but there is already another Atlassian account using the email.
This other Atlassian account might have been created by the user on self sign-up or site administrator through invitation, for example.
Solution
The problem can be solved by releasing the email from the other Atlassian account, changing it to something else, such as emailB+duplicated@domain.com, then pushing the email change from the Identity Provider for the main account again.
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