After upgrading Confluence, Tomcat logs are no longer written on Confluence Installation folder

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Summary

Confluence was upgraded from version 6.15.X or earlier to version 7.0.5 or greater on Windows.

After the upgrade, there aren't new log messages being written on the <confluence_install>/logs folder (see Confluence Home and other important directories)

The Windows service was correctly reinstalled according to the mandatory post-upgrade step on Upgrading Confluence.

Environment

  • Confluence Server or Data Center 7.0.5 or greater (upgraded from 6.15.X or lower)
  • Windows Operating System
  • Confluence is running as a service

Diagnosis

  1. Check the last created/modified date on the catalina.log files. The last message was written prior to the upgrade.
  2. The application logs, on Confluence Home, are being written as expected.

Cause

After the security fix developed on CONFSERVER-58808 - DLL hijacking in Confluence Server Windows installations, Confluence service was modified to run as a Network Service, as opposed to a Local System account. This new user, responsible for running the Confluence service, doesn't have write permissions over the Confluence Install directory.

Solution

Solution 1 - Granting permissions

  1. Check the user set to run the Confluence Service
  2. Grant write permissions to that user over the Confluence Install directory

Solution 2 - Using a dedicated account

  1. Create a dedicated account to run Confluence service on Windows
  2. Modify the Confluence service parameters to use the newly created account

Last modified on Jan 22, 2025

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