Non admin users are unable to use Label or Space Category filters in Quick Search

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When user is attempting to use Label or Space filter in Search, typing in known labels or categories will return no results. 

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When attempting to use filters logged in as confluence-administrators user will continue to work

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Diagnosis

The issue maybe caused by Space Privacy - Extranet for Confluence app, check if you have it installed.

Cause

If you have  Space Privacy - Extranet for Confluence installed, it appears that Visibility setting of "Members can see each other and any user group..." will break Label and Space category filter options.

Solution

Go to ⚙  > General ConfigurationSPACE PRIVACY Configuration > Visibility and change first setting back to Recommended "Members can see all users and groups without restrictions":

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Updated on March 14, 2025

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