Non admin users are unable to use Label or Space Category filters in Quick Search
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When user is attempting to use Label or Space filter in Quick Search, typing in known labels or categories will return no results.
When attempting to use filters logged in as confluence-administrators
user will continue to work
Diagnosis
The issue maybe caused by Space Privacy - Extranet for Confluence app, check if you have it installed.
Cause
If you have Space Privacy - Extranet for Confluence installed, it appears that Visibility setting of "Members can see each other and any user group..." will break Label and Space category filter options.
Solution
Go to > General Configuration > SPACE PRIVACY Configuration > Visibility and change first setting back to Recommended "Members can see all users and groups without restrictions":