Child pages
  • Checking plugin compatibility for Bamboo upgrades

This is the documentation for Bamboo 5.5. View this page for the

Unknown macro: {spacejump}

of Bamboo, or visit the latest Bamboo documentation.

Skip to end of metadata
Go to start of metadata

You can use the plugin manager's 'Upgrade Check' to verify that your plugins will still work after a Bamboo upgrade.

For example, if you are thinking of upgrading from Bamboo 3.1 to Bamboo 3.2, the upgrade check can tell you the following:

  • Installed plugins that are compatible with Bamboo 3.1 and Bamboo 3.2.
  • Installed plugins that are not compatible with Bamboo 3.2 but will be compatible with Bamboo 3.2 if you upgrade them.
  • Installed plugins that are not compatible with Bamboo 3.2, even if you upgrade them to their latest version.

 

Go to the Plugin Manager in Bamboo:
  1. Log in as a user with the 'Admin' global permission.
  2. Click Administration in the top navigation bar.
  3. Click Plugin Manager, in the left-hand panel, under 'Plugins'.

To check the compatibility of your plugins against different Bamboo versions:

  1. Click the 'Upgrade Check' tab.
  2. In the 'Check compatibility for' dropdown menu, select the version of your application to check the plugins against.
  3. Click the 'Check' button.
  4. The page display any of your installed plugins that are not compatible with the selected application version. The compatibility checker will also check the compatibility of the latest available version of each plugin (if not already upgraded). You can click on the name of any of the plugins to view more information about the plugin.

    The plugins are grouped into sections under the following headings:
    • Incompatible – The installed versions of these plugins are not compatible with the selected application version. There are currently no plugin upgrades available that are compatible with the selected application version.
    • Compatible, if upgraded – The installed versions of these plugins are not compatible with the selected application version. However, the plugins will be compatible if you upgrade them. There are buttons allowing you to upgrade these plugins.
    • Compatible if both <the application> and the plugin are upgraded – The installed versions of these plugins are not compatible with the selected application version. There is a plugin compatible with the newer application version, but it is not compatible with the application version you are currently running. You must upgrade the application and then upgrade the plugin. There are buttons allowing you to disable these plugins before proceeding with the upgrade.
    • Compatible – The currently installed versions of these plugins are compatible with the selected application version.
    • Unknown – These plugins may or may not be compatible with the selected application version. If a plugin is not registered with the Atlassian Plugin Exchange, the Universal Plugin Manager cannot check its compatibility with different application versions.

  • No labels