Bamboo search bar searches not showing all results
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When searching projects, plans or deployments in the search box. Some plans are not appearing in the search results.
Environment
All Bamboo versions below 8.2
Cause
This issue is usually caused by incomplete indexes.
Solution
Re-indexing Bamboo by going to CogIcon >> Overview >> Indexing >> Perform a full reindex After completing the reindex all plans should be appearing in the search results.
During the reindexing process you will be able to use Bamboo normally while the process is running, but some reports might produce incomplete results (details).