Unable to process artifacts on Windows Runners due to insufficient disk space


 

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

   

Summary

  • The Bitbucket Windows Runners build process is failing due to an error when attempting to upload the artifacts.
  • The error message generated in the runner.log file is as follows:

    java.nio.file.FileSystemException: D:\atlassian-bitbucket-pipelines-runner\bin\..\temp\uuid\id\artifact\artifact: There is not enough space on the disk.

Cause

The issue stems from insufficient disk space on the disk where the Runners are being executed. This lack of available space prevents the artifacts from being successfully uploaded.

Solution

The solution to this problem is to free up some disk space on the drive where the Bitbucket Windows Runners are being executed. This could involve deleting unnecessary files, moving some files to another disk or storage solution, or increasing the size of the disk if possible.


If the above instructions do not assist in resolving the issue, please raise a support ticket or raise a community support ticket for further assistance with this.

DescriptionUnable to process artifacts on Windows Runners due to insufficient disk space
ProductBitbucket Cloud
Last modified on Jan 17, 2024

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