Cannot update add-ons on the Manage Apps page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When updating the add-ons through the "Manage Apps" page, an error is thrown on the UI with the following message:

1 An error occurred during installation. Refer to the logs for more information

Diagnosis

  • The following NullPointerException error is found in the logs:

1 2 3 4 5 6 7 8 9 2020-04-02 15:22:08,105 WARN [http-nio-8090-exec-10] [atlassian.upm.pac.PacClientImpl] getUpdates The request to check for app updates may take longer than expected because xx apps are installed that could have updates. This may impact the performance of loading the Manage Apps page. -- referer: http://localhost:8090/plugins/servlet/upm | url: /rest/plugins/1.0/installed-marketplace | traceId: 6bc592c38597a483 | userName: admin-chard 2020-04-02 15:22:42,945 WARN [UpmAsynchronousTaskManager:thread-1] [atlassian.confluence.plugin.DatabasePluginScanner] loadNewPluginsFromDatabase Exception when loading plugins from the database -- url: /rest/plugins/1.0/ | referer: http://localhost:8090/plugins/servlet/upm | traceId: 561bacc3fcc3e973 | userName: admin java.lang.NullPointerException at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:877) at com.google.common.io.ByteStreams.copy(ByteStreams.java:104) at com.atlassian.confluence.plugin.DatabasePluginScanner.writePluginData(DatabasePluginScanner.java:150) at com.atlassian.confluence.plugin.DatabasePluginScanner.lambda$null$0(DatabasePluginScanner.java:174)
  • Clearing the plugins cache does not resolve the issue.

Cause

One of the installed plug-ins appears to be corrupt and is blocking UPM.

Solution

Updated on March 21, 2025

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