Profile Picture Missing After an Upgrade

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After an upgrade, Users' profile picture are missing.

Diagnosis

Run the following SQL query in Confluence Database:

SELECT * FROM OS_PROPERTYENTRY WHERE ENTITY_KEY = 'confluence.user.profile.picture';

If the result of the above query is similar to as follows:

ENTITY_NAME;ENTITY_ID;ENTITY_KEY;KEY_TYPE;BOOLEAN_VAL;DOUBLE_VAL;STRING_VAL;LONG_VAL;INT_VAL;DATE_VAL
OSUser_usera;0;confluence.user.profile.picture;5;0;0;usera-47837-pp-img_0793.jpg;0;0;

See this Bug Ticket: CONFSERVER-22298 - OS_PROPERTYENTRY User Property Settings Lost after Upgrade to Confluence 3.5 or higher


If the result of the above query is similar to as follows:

ENTITY_NAME;ENTITY_ID;ENTITY_KEY;KEY_TYPE;BOOLEAN_VAL;DOUBLE_VAL;STRING_VAL;LONG_VAL;INT_VAL;DATE_VAL
CWD_UserA;0;confluence.user.profile.picture;5;0;0;usera-47837-pp-img_0793.jpg;0;0;

Proceed to Workaround

Cause

Part of the Confluence database, in the table: OS_PROPERTYENTRY might not be updated

Confluence VersionOS_PROPERTYENTRY Schema for the Column "
entity_name"
Below 3.5
OSUser_<username>
3.5
CWD_<username>
5.2
USERPROPS-<userkey>

There are possibilities that the upgrade task was somehow corrupted. 

Workaround

  1. Go to the URL:

    <Confluence Address>/admin/force-upgrade.action
  2. Select "embeddedCrowdPropertSetFactoryMigrationUpgradeTask"
  3. Selet Force Upgrade

(info) Please backup your database before performing the above

Should the above workaround does not solve the issue, it is recommended to rollback to previous version and redo the upgrade again, preferably by using the standalone installer. Use the documentation to rollback to your pre-upgraded state Confluence:

How to roll back or restore a previous version of Confluence Data Center


Last modified on Feb 19, 2025

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