Universal Plugin Manager Crashes when Numbered Headings Plugin is Installed

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

The following exception is shown in the logs when using the Universal Plugin Manager (UPM):

com.atlassian.plugins.PacException
	at com.atlassian.plugins.client.service.AbstractRestServiceClient.getEntityFromResponse(AbstractRestServiceClient.java:163)
	at com.atlassian.plugins.client.service.plugin.PluginVersionServiceClientImpl.getCompatibilityStatus(PluginVersionServiceClientImpl.java:176)
	at com.atlassian.upm.pac.PacClientImpl.getProductUpgradePluginCompatibility(PacClientImpl.java:91)
	at com.atlassian.upm.rest.resources.ProductUpgradePluginCompatibilityResource.get(ProductUpgradePluginCompatibilityResource.java:42)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

The following error is shown after doing an upgrade check in UPM:

An error occurred while connecting to the Atlassian Plugin Exchange. For more information about this problem, please refer to the [UPM documentation|http://confluence.atlassian.com/display/UPM/Problems+Connecting+to+the+Atlassian+Plugin+Exchange].

Cause

This problem happens when the Numbered Headings Plugin is installed in Confluence and the UPM does an upgrade check. This issue is tracked by CONF-20511.

Resolution

Disable the Numbered Headings plugin when you want to use the Check feature in UPM, you can enable it again after making the check. If you're still getting the same error after disabling the plugin you may need to uninstall it temporarily.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.