Advanced Roadmap program does not show scheduled dates for completed issues

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The Advanced Roadmap program view does not show "Scheduled start" and "Scheduled end" dates for issues that are in the "Done" category. 

Environment

All Jira versions with Advanced Roadmaps.

Diagnosis

  1. Open the Program that has the missing "Scheduled start" and "Scheduled end" dates from the Plans dropdown.



  2. Go to the scope tab of the program and check the "Status" field of the issues with missing dates("CARS-2" in the example above), they should be in the "Done" category. 
  3. Identify the "Connected Plan" of the program by clicking on "..." next to the program name and selecting Configure. Navigate to the connected plan.
  4. Notice that for issues in the "Done" category although have target dates configured in the plan, they are not shown in the scope tab of the program view. However, for the issues in other categories (TO DO, IN PROGRESS), the scheduled dates are displayed.

Cause

This behavior is an old constraint of how the scheduling works. Programs generate the schedule by essentially performing an algorithmic calculation, part of this algorithm is to only schedule future work. It's only 'forward thinking' so it ignores all completed issues i.e issues in the "Done" category. Since completed issues are not considered for scheduling, "Scheduled start" and "Schedule end" dates are empty for these issues.


Last modified on Nov 23, 2022

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