Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When installing the JIRA Service Desk add-on, the installation process will hang and appears to lock up the Universal Plugin Manager.
When navigating away from the UPM and back again, the installation pop-up will show again and lock up at the same position.
The following appears in the atlassian-jira.log
2015-05-22 09:28:05,431 ThreadPoolAsyncTaskExecutor::Thread 28 ERROR [plugin.osgi.factory.OsgiPlugin] Unable to start the plugin container for plugin 'com.atlassian.servicedesk.plugins.automation.servicedesk-automation-modules-plugin' org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'componentImportBeanFactoryPostProcessor': Unsatisfied dependency expressed through constructor argument with index 0 of type [org.osgi.framework.BundleContext]: : Error loading class [com.atlassian.jira.compatibility.factory.search.SearchServiceBridgeFactory] for bean with name 'searchServiceBridgeFactory' defined in null: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: com/atlassian/jira/compatibility/factory/search/SearchServiceBridgeFactory : Unsupported major.minor version
Cause
This issue surfaces when running JIRA on an unsupported version of Java.
For instance, when running JIRA 6.x on Java 6.
Resolution
The resolution for this issue, is to update the version of Java to a supported version.
Please refer to our Supported Platforms page to find which versions of Java are supported.