Symptom

When viewing your service desk project, you see the following configuration error message:

This service desk project may not work as expected.

 

When you click the message, you see the following details: 

Wait! We need to talk...It looks like you haven't yet moved to our new and improved automation rules. We need to disable your existing issue transitions to make sure your service desk runs smoothly. As a project admin, you can create a "Transition on comment" automation rule here. When you're ready, click below to disable your previous issue transitions and remove this error message.

Cause

Your service desk project workflow has been modified to include customized issue transitions that are no longer supported. When modifying your workflow, you or a previous JIRA administrator likely made the following changes: 

  1. Configured a customer to agent transition by adding the sd.step.key property key and sdWFCustomer property value to a step, and then adding the sd.action.key property key and sdWFCustomerToWFSupport property value to a transition (or action) from that step to another step.
  2. Configured an agent to customer transition by adding the sd.step.key property key and sdWFSupport property value to a step, and then adding the sd.action.key property key and sdWFSupportToWFCustomer property value to a transition (or action) from that step to another step.

Legacy transitions such as those referenced above have been replaced by automation rules, which are much easier for you to configure and manage in each service desk project. The configuration error message will appear in your service desk project until these legacy issue transitions are disabled. 

Resolution

Check your service desk project workflow properties 

We recommend that you view your service desk project's workflow (which can be found by going to  > Issues > Workflows) and examine the properties for each workflow step:

  • If one of your workflow steps has the sdWFCustomer property value, see if you can find a linked transition with the sdWFCustomerToSupport property. If you find one, you have been using the customer to agent transition in your project. You will need to create a corresponding automation rule (e.g. "When issue commented -> If [status of step] -> Perform [transition]").
  • If one of your workflow steps has the sdWFSupport property value, see if you can find a linked transition with the sdWFSupportToWFCustomer property. If you find one, you have been using the agent to customer transition in your project. You will need to create a corresponding automation rule (e.g. "When issue commented -> If [status of step] -> Perform [transition]").

Create a new automation rule

To mimic this legacy transition behavior, you will need to create a new Transition on Comment automation rule:

  1. Open your service desk project and proceed to Settings > Automation.

  2. Select New rule.

  3. Choose Transition on Comment from the list of automation rules. The default rule will mimic both the customer to agent and agent to customer transitions. If you only want to use one of the transitions, you can simply delete the IF condition that doesn't fit your needs. Note that the IF box with the "and user is a customer" condition applies to the customer to agent transition; the IF box with the "and user is not a customer" condition applies to the agent to customer transition:
    . 

  4. Once you have created the needed Transition on Comment rule, free to check out the other automation rule options to help increase your team's efficiency with additional service desk processes. 

Disable remaining legacy transitions

Now that you've created an automation rule to replace legacy transitions, you can resolve this error message.

  1. Open the error message.
  2. Select Disable old transitions. The legacy transitions will be disabled and the configuration error message will be removed.

4 Comments

  1. Automated transitions are configured, however i could not find the error message 'This service desk project may not work as expected.'

    Is there any link to find and disable "disable your previous issue transitions and remove this error message"

    1. Hi Jijo John [Consultant],

      It's possible that the migration task has not yet run in your instance, and the issue will be fixed automatically soon. If you are concerned about the status of automatic transitions in your instance, I recommend filing a support ticket so the team can dig into your logs for more information. 

      I hope that helps! 

      Cheers,
      Sarah

  2. Hi,

     

    Is it possible to create automation rule which will reset timer (or start new one) when agents are bot Assignee and Reporter? Everything works perfect when ticket is updated, from one side by Agent/Asignee and from other side by Reporter/Customer. But when both persons are added to project as Agents, timer keeps counting time even when case is update by reporter (agent). How this can be accomplished, any suggestion please?

  3. The grammar and punctuation on this is pretty bad. It makes it hard to follow.

     

    •  If one of your workflow steps has the sdWFCustomer property value, see if you can find for a linked transition with the sdWFCustomerToSupport property. If you find one, you have been using the customer to agent transition in your project. You will need to create a corresponding automation rule. Create an automation rule like "When issue commented -> If [status of step] -> Perform [transition]"
    • If one of your workflow steps has the sdWFSupport property value, see if you can find for a linked transition with the sdWFSupportToWFCustomer property. If you find one, you have been using the agent to customer transition in your project. You will need to create a corresponding automation rule. Create an automation rule like "When issue commented -> If [status of step] -> Perform [transition]"