After upgrading Jira Service Management to version 4.15 and above, the Assets(Insight) menu button disappears

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading Jira Service Management to version 4.15 and above, the Assets (formerly Insight) menu button disappears and the Assets(Insight) plugin doesn't seem installed

Environment

Jira Service Management 4.15 and above

Diagnosis

  • Assets plugin may not be found in the Jira Administration > Manage apps > Manage apps page depending on the causes stated below

  • You've tried to enable the Assets plugin but there's an error without more description on the page

  • You've tried installing one of the Assets plugins from Atlassian Marketplace but it didn't resolve the issue 

Cause

Since Jira Service Management 4.15, the Assets plugin is installed along with the Jira Service Management application and the version starts with 9.0.2, which is not downloadable from Atlassian Marketplace or anywhere else. The Assets plugin might not be installed/enabled properly during the installation process of Jira Service Management application due to other factors

  1. insight-9.x.y.jar file is not found in <Jira_home>/plugins/installed-plugins

  2. Assets plugin seems installed in the Manage apps page but the Assets menu does not appear on the top of the page, or plugin is disabled and cannot be enabled

Solution

For cause 1, reinstall Jira Service Management application with the steps below.

  1. Back up Jira just in case it's needed.

  2. Head over to Jira Administration > Applications > Versions & licenses page.

  3. Click on the Uninstall link below Jira Service Management application.

  4. A message will pop up with a confirmation to uninstall the application, as well as an option to also remove the license and configuration. Untick the option so that the application license and configuration will remain.

  5. Once the uninstallation is done, you can restart Jira to refresh application cache or just proceed to reinstall Jira Service Management application on the same page.

  6. Once Jira Service Management application is reinstalled, navigate to Jira Administration > Manage apps > Manage apps and verify if Assets is installed. 

    • Depending on the Jira Service Management version as well as Server/Data Center, the Assets plugin may appear under different category. Assets plugin in different instance type and version shows where Assets plugin can be found on the UI.

  7. Insert a license for the Assets plugin if necessary and enable Assets if it's currently disabled. Upon refreshing the page you are viewing, Assets menu should be available at the top of the page and ready to be used.

For cause 2, clear the plugin state with the steps below.

  1. Stop Jira.

  2. Run the SQL query below to clear the state of Assets plugin.

    1 delete from pluginstate where pluginkey like '%jira.plugins.insight%'
  3. Start Jira.

  4. Once logged into Jira as a user with permission to use Assets, the Assets menu should be available at the top of the page and ready to be used. Otherwise, navigate to Jira Administration > Manage apps > Manage apps and verify if Assets is installed, enabled and licensed if necessary.

Other Notes

If further troubleshooting needed, please contact Support with information below.

  • Jira Support zip

  • If Assets plugin can be found installed in the Manage apps page, expand it and share a screenshot of the plugin details

  • Result of the SQL query below

    1 select * from pluginstate where pluginkey like '%jira.plugins.insight%'
  • Any additional information that could help Support to understand the issue better. For example, from which version Jira was upgraded, what other actions have been carried out to try fixing the issue.

Updated on March 19, 2025

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