An "Unexpected" error in "Manage apps" menu - requests to Marketplace are being blocked by a proxy/firewall from customer's environment

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

An "Unexpected error" in "Managed apps" menu is observed for a single user and is not possible to replicate the issue from support side. Standard troubleshooting as per https://confluence.atlassian.com/upm/problems-connecting-to-the-atlassian-marketplace-273875718.html is not working too.

Diagnosis

It is possible in the process of troubleshooting that a HAR file is requested from the user experiencing the problem. In a HAR file excerpt, the server that should return the responses for the below URLs should be AtlassianEdge by default:

Systems like a proxy or firewall could be preventing the URLs to the the Marketplace. The links that are being prevented and getting a 403 forbidden error are:

In the Server's response example, it can be observed that the response comes from Zscaler where AtlassianEdge is expected:

1 2 3 4 5 6 7 8 9 Server's response Full response: 403 Forbidden HTTP/1.1 More info about HTTP status codes in Wikipedia . Headers:Access-Control-Allow-Origin * Cache-Control no-cache Content-Type text/html Content-length 14579 Server Zscaler/6.2

Cause

Network software like a firewall or a proxy are blocking accepting the response and that does not allow the request to reach AtlassianEdge servers.

Solution

Request assistance from the user's networking team to enable the Marketplace URLs on the proxy/firewall software.

Updated on April 2, 2025

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