Attachment field is not appearing on Customer Portal when creating new requests or you can not add it on Request types

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

You've added Attachment field to a Request Type, but customers don't see the field when creating a new request of that Request Type:

OR 

When trying to Edit fields for a Request Type you can not see Attachment listed:



When checking other Request types we can see Attachment field there. If trying to remove it you can not add it back.

Diagnosis

Check the followings from Project settings of the Service Management project:

  1. From the Field Configuration used by the issue type associated with the request type, is Attachment visible or hidden? If hidden, Show it.
  2. The field needs to be on the Create Issue Screen used by the issue type associated with the Request Type.
    1. Check under Project Settings > Screens - and make sure the field is not hidden
  3. Make sure you have proper Permission set for Create Attachments
    1. Under Project Setting > Permissions
    2. If the permissions are set by roles, make sure your user has the roles assigned, under Project Settings > Users and roles
  4. Do you see Attachment field on any other screen in Jira?
  5. Is Attachments disabled in the System settings? It must be enabled from Jira Administration > System > Attachments for the field to be visible.


A more generic KB on missing fields on screens can be found at Fields missing on screens in Jira server.

Last modified on Mar 20, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.