Cannot create or open a specific issue type on the JSM customer portal

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Cannot create or open a specific Issue Type using the Service Desk Portal, it spins and does not load. Other issue types are working properly.

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Symptom

  • It is possible to create a ticket from Jira, but not using the Customer Portal

  • When trying to open a just-created ticket, it fails saying that the user doesn't have permission

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  • Preview of previous tickets created times out

Cause

One of the Custom Fields used by this Issue Type does not have a Global Context created, it was specific for other projects.

Diagnosis

1) Reproduce the issue and observe log files:

The request is failing due to the Default Value provider defined for a field used by this Issue Type:

1 2 3 4 5 2021-04-01 19:59:40,963+0000 http-nio-8080-exec-114 url:/servicedesk/cu...portal/2/create/26 username:xxxxx url:/rest/servicede...portal/2/create/26 username:xxxxx ERROR xxxxx 1199x158246x2 nvg69b 10.0.173.192,10.0.61.131 /servicedesk/customer/portal/2/create/26 [o.a.c.c.C.[.[localhost].[/].[default]] Servlet.service() for servlet [default] threw exception java.lang.NullPointerException at com.atlassian.jira.issue.customfields.impl.AbstractMultiCFType.getDefaultValue(AbstractMultiCFType.java:88) at com.atlassian.servicedesk.internal.fields.defaultvalues.list.MultiUserCFDefaultValueProvider.getMultiUserDefaultValues(MultiUserCFDefaultValueProvider.java:42) at com.atlassian.servicedesk.internal.fields.defaultvalues.list.MultiUserCFDefaultValueProvider.lambda$getDefaultValueIfValid$1(MultiUserCFDefaultValueProvider.java:32) [...]

2) Identify which are the Visible Fields used by the Service Management;

3) Edit each field and check if:

Resolution

  • Make sure all custom fields have a Global Context or context specific to the project

Updated on April 2, 2025

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