Create service request action in Automation doesn't work and gets stuck in loading

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When creating an automation rule in a Jira Service Management project, the create service request action fails to load.

Diagnosis

When we try to create a rule using the Create Service Request action, it gets stuck in loading and you cannot use this action anymore.

Cause

When the create service request action loads, it makes two requests to Jira:
1. Get all the service management projects (taking into account user permission etc)
2. Get all the request types for the first service management project returned in the previous step

If the second request returns an empty collection (because the service management project has not been configured) then the action will not load. Users will see a spinner that goes on forever.

Therefore, when the first service management project doesn't have any Request types, then automation exhibits this behavior. (It could be a DEMO project or a TEST project not in use)

Solution

  1. Navigate to the first service management project in the list of projects ( Link: https://<instance_name>.atlassian.net/jira/projects)
  2. Filter Jira Service Management projects(if you have other types of projects as well)
  3. Navigate to the Request Types of the first project in the list returned in step 2(Project Settings → Request Types)
  4. Add a dummy Request Type in the project. If you prefer, do not add it to any portal groups so that it stays hidden from the project portal.
  5. Navigate to the automation page and try again

Last modified on Dec 26, 2023

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