Create service request in Automation with hidden fields in the Request Form

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

It is not possible to create Service Requests from Automation with hidden fields on their Request Form, as the value for those presets fields can't be set at the moment of the request creation.

This KB helps you overcome this limitation.

Diagnosis

When the Create service request action is used in an Automation rule for a Request Type with hidden fields, you will see them marked as (deleted field?).


If you try to set them within the action, the automation rule will fail with the following: 

Unknown fields set during create, they may be unavailable for the project/type. Check your custom field configuration. Fields ignored - [Your hidden field]



The impact is greater when the field is required, as you can't leave the field empty.

Cause

When a field value is hidden for a Request Type, its preset value needs to be set. When the Create service request action is used in an Automation rule for that Request Type, the value of the preset field needs to be configured separately.
We have a Feature request to provide this functionality: JSDCLOUD-14392 - Ability to remove the preset field from the Create service request in Automation

Solution

While all of us wait for this functionality to be available, you can update the Automation rule or the project settings to get the desired results. 

There are two possible workarounds to this situation. The first and simpler one will be to make the field/s visible in the Request Form. The second will require replace the Create service request action within the automation rule.

Option 1: Make the field/s visible in the Request Form for the desired Request Type

You must be a project admin to customize fields on request types.

To customize fields for a request type:

  1. From your service project, go to Project settings , and then Request types.

  2. Select the relevant work category in the left hand navigation panel.

  3. Select the request type you want to customize.

  4. Select Request form to update the request form.

  5. Add, remove, and rearrange fields as desired:

    • to add a field, drag and drop it into your desired location from the panel on the right

    • to remove a field, drag and drop it into the panel on the right

    • to rearrange fields, drag and drop them into your desired order

  6. Make sure that fields are visible:

    • If one of the fields you want to complete within the automation rule is grayed out and marked as HIDDEN, make it visible again by unchecking the box next to Use preset value and hide from portal


Reference article on how to customize a Request Type - Customize the fields of a request type

Option2: Use the Create Issue action in combination with Edit request type in order to replace Create service request

You can solve this problem by using the Create issue action instead of Create service request. This way, you can set the Summary field to be copied from the 'Current issue' without unhiding the field in the form.
This would cause requests to be created without a Request type at first, which can be resolved by adding an Edit request type action after it.

Updating your automation rule

You can Create an automation rule with the following configuration

  1. From your service project, go to Project Settings > Automations
  2. Identify the rule that is affected by this limitation
  3. Click on its name to open the Editor
  4. Create a new action Create Issue below the Create service request one.
    • Select the project and the Issue type. This should match with the Request Type you want to select later.
    • Select and complete all the fields you need. Here you won't have the limitation of being visible on the Request Form.
  5. Create a new Branch below this action.
    • Choose Branch rule / related issues
    • For Most recently created issue
    • For
  6. Within the branch create a new Edit request type action 
    • For Request type choose the desired Request Type
  7. Select the original Create service request action and delete it.
  8. Click on Save and Turn it on

Or, Create it based on the following video:


You can also import the following rule and adapt it to your business case: automation-rule-KB-create-service-request-hidden-fields.json


Reference article on how to import the above rule to your site - Import and export Jira automation rules

(info) The rule is in a disabled state so that it doesn't run automatically before making the necessary changes are made to suits your needs and the necessary testing is done.
Next, It's important to select the right 
Project Scope after importing the new rule. Also, leave the  Import rule owners unchecked. 



Contact Atlassian support if you have any questions. 


Last modified on Jan 27, 2025

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