Issue Security Levels Locks Issues From All Users

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Symptoms

Issues are no longer viewable, and the following appears when trying to access an issue within the project recently added to Issue Security:

It seems that you have tried to perform an operation which you are not permitted to perform.

Looking at the 'Edit Issue Security Levels' there are no entries under 'Users / Groups / Project Roles' and/or after adding users or groups they are still displaying the same error.

Diagnosis

You have Issue Level Security Configured and are unable to update Users or Groups by adding them in the 'Edit Issue Security Levels' management page (Per the documentation provided here: Configuring issue-level security ).  This can occur when you assign the security level to a 'Project' before you add any 'Users' or 'Groups'.  

Cause

There seems to be an issue with associating large number of issues to the security scheme at the same time currently we have only seen this occur on instances associating projects with ~400 or more issues.

>> Caused by this BUG  JRA-43038 - Getting issue details... STATUS

the error Occurs after the timeout and one of the following operations occurs causing the association to fail and no groups, or users are set to the security policy:

  • Reindex
  • Refresh the page while timed out
  • Running the same association a second time while the other association is occurring in the background and not visible in the UI


>> See  JRA-40231 - Getting issue details... STATUS

>> See  JRA-32546 - Getting issue details... STATUS

Resolution

  • These Steps must be performed by an administrator with DataBase access, if you are using the Atlassian Cloud platform Please fill out a Trouble Ticket at http://support.atlassian.com and reference this Knowledge base article;
  • Manually remove issue level security from the DataBase;
  • Locate the effected tables in the DB with this command (Project ID will vary):
jira=> SELECT id,project,security,issuenum FROM jiraissue where project = 10000;
  id   | project | security | issuenum 
-------+---------+----------+----------
 15425 |   10000 |          |        1      <<< test issue with no issue level security set
 12317 |   10000 |    10001 |        2      <<< issue not showing up (locked issue) with security value assigned to no one Including sysadmin
(2 rows)
  • Remove the Security from the effect rows
    • For a single Issue:
UPDATE jiraissue SET security = NULL WHERE id  = **Put ID Here** AND issuenum = **put IssueNum Here**;
  • For An Entire Project:
UPDATE jiraissue SET security = NULL WHERE project = **put Project here**;
  • You Can now add users or groups to the Issue Level Security settings, and assign to a project. Per the documentation provided here:  Configuring Issue-level Security


Last modified on Mar 21, 2024

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