KB settings are broken when the server ID of the linked Confluence is changed

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Imagine the use case below:

  1. Search for KBs and a few article links appear in the search result.
  2. You click on the first one to view the article, however, it says page not found.
  3. When you check on the URL of the article, it's pointing to the production Confluence instead of staging Confluence.
  4. You then check the server ID of both the Confluence instances and realize that the server ID is the same.
  5. You change the server ID of the staging Confluence based on this article: How to change the server ID of Confluence.
  6. You recreate the AppLinks with the exact same configuration.
  7. You notice that the integration between the Service Management project and the Confluence space for KB is broken and there's no other way to fix it other than removing the integration and re-configure it.

Diagnosis

Diagnostic Steps

  1. Retrieve the ID of the AppLinks for Conflluence.

    SELECT SUBSTR(a.property_key,16,36) as "Application Key", b.propertyvalue as "Application Name" FROM propertyentry a join propertystring b on a.id=b.id where a.property_key like 'applinks.admin%name';
  2. Execute the SQL query below in the same database to check the integration of KB space with Service Management project.

    select * from "AO_54307E_CONFLUENCEKB";
  3. Expected that the value in the APPLINKS_APPLICATION_ID column is different than the ID copied in step 1.

Cause

The KB integration for the projects are still referring to the obsolete AppLinks ID.

Resolution

Warning

Please ensure that a backup have been done prior to the change below. Below modification is not guaranteed to be supported by Atlassian and any changes should be done in own risk.


  1. Back up the database.
  2. Execute the SQL query below to update the AppLinks ID. Replace the new AppLinks ID (retrieved in step 1 of the diagnostic steps) as the new "APPLINKS_APPLICATION_ID" and replace the (confluence_URL) in the query below with your linked Confluence URL.

    update "AO_54307E_CONFLUENCEKB" set "APPLINKS_APPLICATION_ID"='___________________________' where "APPLINK_URL"='(confluence_URL)';
  3. Re-run the query in step 3 to confirm if the AppLinks ID has already been updated correctly.

  4. Restart Jira.
  5. Verify if the KB integration for each Service Management project has been fixed.


Last modified on Nov 23, 2020

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