Jira Cloud Migration Assistant (JCMA) Error: Board is referring to a non-existent saved filter / Board is referring to an in-existed saved filter
Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When running a migration plan to migrate Jira Server projects to Jira Cloud, the Jira Cloud Migration Assistant (JCMA) plugin may report errors migrating boards that are tied to non-existent filters.
Environment
Jira Server with Jira Cloud Migration Assistant 1.0 and higher
Diagnosis
The following example error may be seen in the JCMA-provided error logs:
2021-08-05 14:31:08.300 ERROR TESTPROJECT project-export Board 'ACME Board' is referring to an non-existent saved filter ID: 10001. Configure an existing filter for this rapid view.
or
2025-03-11 07:15:21.389111518 ERROR TESTPROJECT project-export Board 'TEST Board' is referring to an in-existed saved filter ID: 51673. [JCMA 135] Configure an existing filter for this rapid view.
In this example, project TESTPROJECT indicates that the board named ACME Board is tied to a non-existent filter with filter id: 10001. We can confirm that the filter doesn't exist by running a select on the database to check for the problematic filter ID:
select * from searchrequest where id = <Affected-Filter-ID>;
Note that this query has been tested with Postgres but may need additional adjustments to work with other database flavors. You'll replace the <Affected-Filter-ID> value with the value seen from your JCMA logs.
Additionally, if you want to check what other boards reference the broken filter ID, you can run the following query:
select * from "AO_60DB71_RAPIDVIEW" where "SAVED_FILTER_ID" = <Affected-Filter-ID>;
Cause
The issue is caused because the referenced boards tied to projects included in a given migration plan are pointed to a filter that no longer exists. This causes the board reference to the filter to become invalid. The workaround is to update the filter configured on the referenced boards to an existing filter id, which can be performed in bulk or via ad-hoc updates.
Solution
Backup Your Database Prior to Committing Changes
As with any changes that involve direct database updates, please backup your database prior to making any changes in production.
First you will need to identify which filter you would like to replace in the board's referenced configuration. If you only wish to fix one board at a time, you can fix the board configuration via the UI by referencing this documentation: Configure Filters
If you need to replace the non-existent filters to connected boards in bulk, you can do so via a bulk change to the database.
Update "AO_60DB71_RAPIDVIEW" set "SAVED_FILTER_ID" = <NEW-Existing-Filter-ID> where "SAVED_FILTER_ID" = <Old-Nonexistent-Filter-ID>
Other Notes
For troubleshooting other JCMA related errors, please refer to this documentation for help Troubleshooting errors and non-migrated entities with the Jira Cloud Migration Assistant