How to Disable/Reset 2FA on Bitbucket Cloud and Atlassian Account

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

This documentation article provides instructions for disabling/resetting 2FA on your Bitbucket Cloud account and explains the difference between Atlassian Account 2FA and Bitbucket Cloud 2FA.

Diagnosis

The Bitbucket Cloud login process is separate from the login process for your Atlassian account, essentially you will first need to authenticate with your Atlassian Account before you are able to authenticate with your Bitbucket Cloud account.

This means that if you have 2FA enabled on both, you would need to first resolve the 2FA issue with your Atlassian account before proceeding with resolving it for your Bitbucket Cloud account.

The usual diagnostic process is as follows:

  • You attempt to log in to your Bitbucket Cloud account and are prompted for your 2FA code, but you:
    1. Changed your 2FA device (i.e. mobile/Yubikey)
    2. Cannot remember/generate the code
    3. Wish to disable 2FA from your account altogether

Bitbucket Cloud 2FA vs Atlassian 2FA

Please refer to the screenshots below to determine which level the 2FA issue currently exists at.

  • Bitbucket Cloud Account 2FA (phone/laptop icon):

  • Atlassian Account 2FA (castle icon):

Solutions

With reference to the above screenshots, you will need to follow the steps below based on the type of 2FA that you are trying to reset/disable.

Bitbucket Cloud 2FA

  1. When you are trying to log in, after inputting the password you will come to a prompt asking you for the 2FA code - you will need to click Forgot code

  2. You will then be presented with this screen - click the Send recovery email button
  3. You will receive an initial email stating that you will need to wait 24 hours for a one-time login link
  4. After the 24-hour waiting period, you will receive a secondary email with the aforementioned one-time login link; Please note that the recovery link will expire in 24 hours
  5. Follow the instructions within the email and you should then be able to log in to your Bitbucket Cloud account with 2FA disabled
  6. We have a guide for enabling two-step verification on your account that you can follow if you wish to re-enable it


The 24-hour waiting period might be a long time to wait before being able to access your account. However, this waiting period is a security measure to prevent unauthorized individuals from exploiting this recovery method and cannot be overridden.
If the above steps do not resolve the problem - you will need to raise a support ticket or raise a community support ticket for further assistance. 

Atlassian 2FA

  1. When you are trying to log in, after inputting the password you will come to a prompt asking you for the 2FA code - you will need to click Can't use your phone
  2. You will now be prompted to enter a 24-character emergency recovery key. If you have the 24-character recovery key, enter this key and you can log in and jump to Step 8.
  3. If you cannot find the key, click on the Can't find your recovery key button
  4. You will then be presented with this screen - click the Send recovery email button
  5. You will receive an initial email stating that you will need to wait 24 hours for a one-time login link
  6. After the 24-hour waiting period, you will receive a secondary email with the aforementioned one-time login link; Please note that the recovery link will expire in 24 hours
  7. Follow the instructions within the email and you should then be able to log in to your Atlassian Account
  8. Once logged in, you can access Two-step verification settings by clicking Security > Manage two-step verification - type the account password and click the Unlock settings button.
  9. Now you can click the Disable button and set this up again on your new device, or simply leave it disabled.
  10. We have a guide for enabling two-step verification on your account that you can follow if you wish to re-enable it


The 24-hour waiting period might be a long time to wait before being able to access your account. However, this waiting period is a security measure to prevent unauthorized individuals from exploiting this recovery method and cannot be overridden.
If the above steps do not resolve the problem - you will need to raise a support ticket or raise a community support ticket for further assistance. 

DescriptionDisable/Reset 2FA on Bitbucket Cloud and Atlassian Account
ProductBitbucket Cloud



Last modified on Sep 15, 2023

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