A specific calendar disappears when adding another Calendar in My Calendars page

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Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

User has a single calendar in their Calendar page, but when subscribing/watching additional calendars, the calendar already added is not visible anymore.

Environment

Confluence 7.19.X and earlier versions
Confluence 8.1.X

Diagnosis

This issue is related to certain UUID values containing multiple digit-only segments. Hence, to confirm if your user is affected by this issue, it is needed to review the UUID associated with this user's subscriptions. 

SELECT user_key FROM user_mapping WHERE lower_username = '<username>';
SELECT *
FROM "AO_950DC3_TC_SUBCALS" tc
LEFT JOIN "user_mapping" um ON um."user_key" = tc."CREATOR"
WHERE um."user_key" = '<user_key_from_query1>'
AND "PARENT_ID" IS NULL AND "SUBSCRIPTION_ID" IS NULL
ORDER BY 1,2

As an example, if the previous query retrieves the following three IDs, it is noticeable that Calendar1 has an UUID value which consist of multiple consecutive digit-only segments:

  • 6333598f-5985-4469-bc90-4116dbfaa8fe (Calendar1)
  • 63e9e06b-4865-4ab0-ac03-a9726c3ab9ba (Calendar2)

Cause

The actual problem in this issue is that Team Calendars cannot return the correct calendars for certain UUIDs even though they exist in the DB. This causes certain calendars to be inaccessible to certain users or groups of users. It can also cause affected calendars to be uneditable.

Further information is available in bug: 

CONFSERVER-81477 - Getting issue details... STATUS

Please check our KB article User is unable to add an Existing Calendar in My Calendars page as a different side effect of this same bug when the user is just a Watcher/Subscriber of the affected Calendar

Solution

The only solution that guarantees not to reproduce the issue anymore is to upgrade your instance to Confluence 8.2.0 or later version. 

Workaround

As the actual UUID affected belongs to the creator of the Calendar, it is needed to recreate it from scratch: 

  1. Export the affected Calendar to an ICS file (Right click on the calendar's name > Export to iCalendar)
  2. Check who are the subscribers and watchers of the affected calendar with the problematic UUID (in this example, 6333598f-5985-4469-bc90-4116dbfaa8fe). 
    You can use our current KB articules to check the users list in the Database side:
  3. Check if there are any Restrictions applied to the affected Calendar (Right click on the calendar's name > Edit... > Restrictions)
  4. Import the ICS file with a different Calendar Name (... > Import Calendar)
  5. Add manually the Restrictions, if any.
  6. Notify the subscribers and watchers to manually add themselves to the new Calendar created.
  7. Remove the affected calendar, using the option Permanently delete this calendar for all users. (Right click on the calendar's name > Remove...)
  8. If you wish, you can rename the new calendar to its former name (Right click on the calendar's name > Edit...)


The new imported Calendar might generate new UUIDs which consist of a multiple consecutive digit-only segments, which will trigger the bug once more. The workaround can be executed multiple times until all the UUIDs are valid, but this does not prevent either that future calendars or subscriptions trigger the issue again. 





Last modified on Dec 22, 2023

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