Confluence Manage Apps page not loading due to too many outdated apps.
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The Manage Apps page on Confluence is not loading or taking too long to load.
Diagnosis
When checking the logs, you can see a similar log entry in atlassian-confluence.log.
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2024-02-16 16:55:41,145 WARN [http-nio-8090-exec-4 url: /rest/plugins/1.0/installed-marketplace; user: admin] [atlassian.upm.pac.PacClientImpl] getUpdates The request to check for app updates may take longer than expected because 99 apps are installed that could have updates. This may impact the performance of loading the Manage Apps page.
-- referer: https://baseurl/plugins/servlet/upm | url: /rest/plugins/1.0/installed-marketplace | traceId: xxxxxxxxx | userName: admin
Cause
This behavior is caused by the number of apps with upgrades available. It will take the Universal Plugin Manager(UPM) a long time to process all the available updates.
Solution
Wait for the page to load and update any apps for which there is an update available.
Incompatible apps can cause instability in your instance, consider uninstalling apps that are not used or that are out of date with no available updates.
After apps have been updated, clear the plugins cache.
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