The Workbox notifications icon on upper-right is missing or not appearing
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The Workbox notification icon is missing from the upper right of Confluence.
Causes
There are multiple reasons that can cause the Workbox icon to not display. Below are the causes and the respective resolutions are in the Resolution section:
Cause 1 - The version of Confluence is 4.2 or below
Cause 2 - Confluence 5.4 or earlier is running on Clustered edition
Cause 3 - The Workbox plugins are not enabled
Cause 4 - In-App Notifications are not enabled
Cause 5 - Apache mod_disk_cache
Resolutions
Resolution 1 - The version of Confluence is 4.2 or below
The Workbox feature was not introduced into the product until 4.3. The resolution is to upgrade to 4.3 or higher.
Resolution 2 - Confluence 5.4 or earlier is running on Clustered edition
As our documentation illustrates, the Workbox feature is not available on Clustered editions at this time:
The workbox is not available in clustered environments. The plugin will be installed and enabled, but it will detect that the site is in clustered mode and will not display the dialog.
There is a feature request to bring this functionality to Clustered environments, which is being tracked here: CONF-27248 - Getting issue details... STATUS
Resolution 3 - The Workbox plugins are not enabled
If you are running non-Clustered Confluence versions 4.3 and higher and the Workbox is still not appearing, check that the plugins which provide this functionality are enabled. They might have been disabled by a Confluence administrator or were not loaded properly due to a technical issue.
How to check these plugins:
- Navigate to
Confluence Admin > Manage Add-Ons
- In the drop-down menu, select
System
to display system plugins - Look for the following plugins and ensure that these plugins, along with all of the modules within each, are enabled:
Workbox - Common Plugin
Workbox - Confluence Provider Plugin
Workbox - Host Plugin
For more information on how to enable or disable a plugin in general, please see: Disabling or Enabling a Plugin
Resolution 4 - In-App Notifications are not enabled
Navigate to Confluence Admin >> In-App Notifications
and switch to displays in-app notifications
Resolution 5 - Apache mod_disk_cache
If you are running Confluence with Apache, there is an option of Configuring Apache to Cache Static Content via mod_disk_cache . If the user running Confluence does not have access to the CacheRoot directory set in the httpd.conf (e.g. /etc/httpd/conf/httpd.conf), the cache will not be properly retrieved and the notification icon will only display on the first load after clearing the browser cache. Make sure the directory has read/write access to the user running Confluence.
<IfModule mod_disk_cache.c>
# "/s" is where Confluence serves "static" stuff. Instruct Apache to cache it:
CacheEnable disk /s
CacheIgnoreHeaders Set-Cookie
CacheRoot "/var/cache/mod_proxy"
</IfModule>
This step documents a configuration of Apache, rather than of Confluence itself. Atlassian will support Confluence with this configuration, but we cannot guarantee to help you debug problems with Apache. Please be aware that this material is provided for your information only, and that you use it at your own risk.