Plugin not visible in Find New Apps

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

A third-party plugin is not showing up on the Find new apps page in Bamboo, thus the plugin can't be installed.

Environment

All supported versions of Bamboo.

Diagnosis

When going to the Cog icon > Manage apps > Find new apps and searching for an existing plugin, it is not retrieved and cannot be installed directly through the UI.
A "No apps matching your search criteria are available for installation in your Bamboo instance." message is shown.


Cause

Apps that do not officially support the Bamboo version you're running are not retrieved on the Find new apps page.

Solution

Install the app manually:

  1. Find the plugin on Marketplace and open its page.
  2. Go to the Versions tab and open See all versions.
  3. Either download the JAR from the most recent version or copy the URL from the Download button.
  4. On Bamboo, click the Cog icon > Manage apps > Upload app.
  5. On the pop-up, either select the downloaded JAR file or paste the download URL you've copied.
  6. Hit Upload.

The app should then be installed. You'll see that it gets marked as Incompatible. This is because the plugin vendor has yet to update their app to be officially compatible with this version of Bamboo (and newer ones).

This also means that the plugin might or might not work properly and that its functionalities and features might be limited. However, there's also a chance that it'll work just fine, but you'd have to test it further to know that.

If you see any issues with the app itself and its functionalities due to the unsupported version, please reach out to the plugin developer. Contact information is available on the plugin's Marketplace page, in the Support tab.

The UI will also show you a Request update option to let the plugin vendor know you'd like their app to be compatible with your current version of Bamboo.

Last modified on Aug 26, 2022

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