Automation For Jira - notification emails are not always sent when a rule fails
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When an automation rule fails to execute due to various reasons (configuration issue, throttling issue...), a notification email should be sent to the owner of the rule.
This knowledge base article describes a scenario where the notification will not be sent any time the rule fails, as illustrated below:
- Let's take the example of the automation rule below. We can see in the audit logs that the rule failed several times to execute:
- However, only 1 notification email was sent:
Environment
- Jira Server/Data Center on any version from 8.0.0
- Automation for Jira on any version from 7.4.0
Diagnosis
- Go to the Rule Details page of the Automation Rule
- Check the setting Notify on error and verify that it is set to E-mail rule owner once when rule starts failing after success:
Cause
When the option E-mail rule owner once when rule starts failing after success is selected, a notification email will only be sent the first time the automation rule failed after the last successful execution.
Going back to the example of rule audit logs from the Summary section of this article, we can see that the rule failed several times in a row without any success in between. In such case, only the 1st failed execution will trigger a notification email:
Solution
If you wish to receive a notification email for each single failed execution, change the setting Notify on error to E-mail rule owner every time this rule fails.