Bamboo Security Advisory 2013-07-16

This advisory discloses a security vulnerability that we have found in Bamboo and fixed in a recent version of Bamboo.

  • Customers who have downloaded and installed Bamboo should upgrade their existing Bamboo installations to fix this vulnerability.  
  • Atlassian OnDemand customers are not affected by any of the issues described in this advisory.

Atlassian is committed to improving product security.

The vulnerability listed in this advisory is a vulnerability in a third-party framework - Struts 2 / WebWork 2 that is used by Bamboo. The vulnerability has been independently discovered by Atlassian and reported to the Struts maintainers.

More details about the underlying Struts vulnerability CVE-2013-2251 are available at the CVE database and in the Struts advisory.

If you have questions or concerns regarding this advisory, please raise a support request at

OGNL injection in WebWork 2


Atlassian rates the severity level of this vulnerability as critical, according to the scale published in Severity Levels for Security Issues. The scale allows us to rank the severity as critical, high, moderate or low.

This is an independent assessment and you should evaluate its applicability to your own IT environment.


We have fixed a vulnerability in the third-party web framework WebWork 2, which is a part of the Struts web framework. In specific circumstances, attackers can use this vulnerability to execute Java code of their choice on systems that use these frameworks. In the case of Bamboo, the attacker needs to be able to access the Bamboo web interface. A valid user account is not required to exploit this vulnerability.

Customers should be advised that this affects all versions of Bamboo, except Bamboo OnDemand, Bamboo 4.3.4 and Bamboo 4.4.8 or later.  Bamboo 5.0 is not affected. The issue can be tracked here: BAM-13387 - Webwork 2 code injection vulnerability Resolved

Risk Mitigation

If you are unable to upgrade or patch your Bamboo server: as a temporary workaround, you can do the following:

  • Block access to all URLs on a Web Application Firewall or a reverse proxy that contain any of the following strings: "redirect:", "action:" or "redirect-action:" strings. A partial example for an nginx server is below. Note that the example only covers the "redirect:" prefix and does not account for any URL encoding that may be present.


  • Block access to your Bamboo server from untrusted networks, such as the Internet.


This vulnerability can be fixed by upgrading Bamboo to either version 4.3.4, 4.4.8 or later. There are no patches available for this vulnerability — for any questions, please raise a support request at

The Security Patch Policy describes when and how we release security patches and security upgrades for our products.

Upgrading Bamboo

The fix versions for this vulnerability are described in the 'Description' section above.

We recommend that you upgrade to the latest version of Bamboo. For a full description of the latest version of Bamboo, see the release notes. You can download the latest version of Bamboo from the download centre.

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport