Application Link failed with "No application link found with the id" error

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Establishing an Application link from another Atlassian application to Bamboo will succeed. However upon checking its integration, such as Build tab on JIRA project, which connected to Bamboo, the application link will fail. The Application link method is using OAuth, and it will fail with the following error message.

From Bamboo:

The request token you are trying to authorize is not valid. Please try another token. (Close this dialog, then go back to the site requesting access and tell it to try again.)

Other Application:

Note: The Application ID could be different among different JIRA or Bamboo servers

Authentication failed!
No application link found with the id "c074c52d-5bed-389b-8b79-86b3ef4ef802"

Diagnosis

With OAuth authentication, the server needs acknowledgement from the other application. In order to get approved, the application will be redirected to the other application. For example from JIRA to Bamboo and vice versa. After approval it should get redirected to the default application. Check on the browser URL, if it didn't get redirected back to default application, it means you encountered this issue.

Cause

This issue is caused by rewrite rule in proxy settings. The URL can't be redirected back, due to the rule is not letting the application to do so.

Resolution

Bypassing the rewrite rule in your proxy settings or http server should solve this issue.

If you are using IIS, please do not use "reverse rewrite host in response headers" configuration.

Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.