Bamboo agent is not starting with error: Unable to load trust store
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
This article covers a scenario where the Bamboo agent does not start with below error as it is unable to access the certificates.
WARN [WrapperSimpleAppMain] [RemoteAgentHttpClientFactory] Unable to load trust store
Environment
The issue was observed on Bamboo 9.2.12, but other versions may be affected.
Diagnosis
Checking the <bamboo-agent-home>atlassian-bamboo-agent.log
file below warning message can be seen.
INFO | jvm 1 | 2024/04/04 15:14:32 | 2024-04-04 15:14:32,919 WARN [WrapperSimpleAppMain] [RemoteAgentHttpClientFactory] Unable to load trust store
INFO | jvm 1 | 2024/04/04 15:14:32 | java.io.FileNotFoundException: /path/to/bambooKeyStore.jks (No such file or directory)
Checking the <bamboo-agent-home>conf>wrapper.conf
file to verify the path of the keystore.
# The Bamboo Agent home configuration file
wrapper.java.command=/path/to/java
wrapper.java.additional.3=-Djavax.net.ssl.trustStore=/path/to/bambooKeyStore.jks
Cause
Bamboo agent is not able to find the bambooKeyStore.jks
file.
Solution
Make sure that the key store file is located in the same path where it's defined in the wrapper.conf file
and the Bamboo agent user has the correct permissions to access it.