Bamboo Data Center remote agent fails to connect: No route to host (Host unreachable)
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When trying to connect a remote agent to Bamboo Data Center, the connection fails and the following error is present in the <agent-home>/atlassian-bamboo-agent.log
:
WARN [ActiveMQ Task-1] [FailoverTransport] Failed to connect to [tcp://<BAMBOO_URL>:54663?wireFormat.maxInactivityDuration=300000] after: 1 attempt(s) with No route to host (Host unreachable), continuing to retry.
Environment
The solution has been validated in Bamboo Data Center 9.6 but may be applicable to other versions.
Diagnosis
The following error is present in the <agent-home>/atlassian-bamboo-agent.log
around the time of the failed connection attempt:
INFO | jvm 949 | 2024/06/24 14:48:46 | 2024-06-24 14:48:45,956 INFO [AgentRunnerThread] [AgentRegistrationBean] Registering agent on the server,
INFO | jvm 949 | 2024/06/24 14:48:46 | 2024-06-24 14:48:46,171 WARN [ActiveMQ Task-1] [FailoverTransport] Failed to connect to [tcp://<BAMBOO_URL>:54663?wireFormat.maxInactivityDuration=300000] after: 1 attempt(s) with No route to host (Host unreachable), continuing to retry.
INFO | jvm 949 | 2024/06/24 14:53:01 | 2024-06-24 14:53:01,220 ERROR [ActiveMQ Task-1] [FailoverTransport] Failed to connect to [tcp://<BAMBOO_URL>:54663?wireFormat.maxInactivityDuration=300000] after: 10 attempt(s)
INFO | jvm 949 | 2024/06/24 14:53:01 | 2024-06-24 14:53:01,232 INFO [ActiveMQ Connection Executor: unconnected] [PooledConnectionFactory$1$1] Expiring connection ActiveMQConnection {id=ID:<BAMBOO_URL>-35861-1719265725993-1:1,clientId=ID:<BAMBOO_URL>-35861-1719265725993-0:1,started=false} on IOException: No route to host (Host unreachable)
Cause
The root cause is No route to host (Host unreachable). This means the agent host doesn't recognize the Bamboo URL or cannot connect to the Bamboo ports due to a firewall/network issue.
Solution
Verify the URL in the error message (between tcp:// and :54663) and validate that there's connectivity from the remote agent machine to Bamboo Data Center. You can run the following commands from the agent's terminal:
ping <BAMBOO_URL> telnet <BAMBOO_URL> 54663
- Engage your Network team to adjust any firewall settings that might be blocking the connection between the two machines.
- Once connection can be established, restart your remote agent.