Bamboo makes inactive sessions to the database and reached process threshold
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Bamboo makes inactive sessions to the DB. This cause the DB to reach the limit of connections.
Bamboo expects to connect to the IP address directly attached to the Database host.
Environment
Oracle
Bamboo 6, 7, 8
Diagnosis
Bamboo should only make connections to a single IP address hosted by the Database server with no DNS load balancing. Bamboo does not support connecting to Oracle RAC, SCAN VIP Addresses, nor any type of DNS load balancing.
Solution
Remove multiple IP address from DNS records. Make sure Bamboo can only make connections to one IP address and the IP address is not a SCAN VIP Addresses. Or use an IP address in your JDBC driver string.
Feature Request for this feature:
BAM-20578 - Getting issue details... STATUS