Bamboo UI is inaccessible though service is up and running.
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Bamboo UI in inaccessible though the Bamboo service is up and running.
Environment
Issue seen on Bamboo 8.1.8, but this issue might be applicable for any supported version.
Diagnosis
While accessing Bamboo via the base URL on the web browser it will not be accesible and there will be below error shown on the screen after sometime.
Internal server error
Go to...
Site homepage
A system error has occurred - our apologies!
Please create a problem report on our support system at https://support.atlassian.com with the following information:
Stack Trace:
org.springframework.transaction.CannotCreateTransactionException: Could not open Hibernate Session for transaction; nested exception is org.hibernate.exception.JDBCConnectionException: Unable to acquire JDBC Connection
at org.springframework.orm.hibernate5.HibernateTransactionManager.doBegin(HibernateTransactionManager.java:598)
When we check the Bamboo service by running ps -ef | grep bamboo, it will be shown as running.
On the Bamboo logs ( atlassian-bamboo.log ) below error would be seen.
Caused by: org.hibernate.exception.JDBCConnectionException: Unable to acquire JDBC Connection
Caused by: java.sql.SQLTransientConnectionException: HikariPool-2 - Connection is not available, request timed out after 30000ms.
Cause
The cause of the issue is the DB which is connected to Bamboo is either not available or Bamboo is not able to make new connections with the DB.
Solution
First check with your Infrastructure team regarding availability of DB, if it is up and running. There are couple of Instances where the DB was in the maintenance mode and not available and Bamboo was trying to access it and giving the error in logs. Whenever there is any maintenance activity on the DB side it is always a good practice to shutdown Bamboo and restart it post DB in up and running.
There can another reason why connections are not available as Bamboo has exhausted the maximum available connection which is configured. First check with your DBA's regarding how many maximum connections Bamboo can make with the DB, post that below parameter can be modified in bamboo.cfg.xml file and Bamboo needs to be restarted for the changes to take effect.
<property name="hibernate.hikari.maximumPoolSize">170</property>
Please change the value accordingly as advised by your DBA's