Bamboo url not accessible after pausing server
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
If the Bamboo server is paused and later resumed by navigating to ⚙️ > Administration > Manage Apps > Pause Server or Resume Server, the platform may become inaccessible.
A restart of the server resolves the issue temporarily, allowing users to gain access again. However, the problem can recur if the server is paused and resumed again.
Environment
This issue has been observed on Bamboo 9.2.3 but it could potentially affect any supported version.
The database in use is Oracle.
Diagnosis
The problem arises when the Bamboo Server is paused and then resumed. An error message appears in the <bamboo-home>atlassian-bamboo.log file:
WARN [10-BAM::PlanExec:pool-13-thread-3] [PoolBase] HikariPool-2 - Failed to validate connection oracle.jdbc.driver.T4CConnection@1ecdba9 (IO Error: Invalid Operation, NOT Connected). Possibly consider using a shorter maxLifetime value.
Cause
The issue is caused by a loss of database connection, resulting from mismatches in the configuration settings between the database driver and the database server.
Solution
To address this issue, increase the wait_timeout setting in the database to align with the default maxLifeTime value, which is typically around 30 minutes. This action, as suggested by the error message, should help mitigate the problem