BambooImportException: Import file is corrupted. Can't find any files to import when importing to Bamboo
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When attempting to import a Bamboo export zip into Bamboo the UI shows: Import file is corrupted. Can't find any files to import. The following exception is logged to <bamboo-install>/logs/catalina.out
:
2016-07-20 08:05:25,706 ERROR [http-nio-8080-exec-22] [SetupImportDataAction] Failed to import
com.atlassian.bamboo.migration.exception.BambooImportException: Import file is corrupted. Can't find any files to import.
at com.atlassian.bamboo.migration.XmlMigrator.validateXml(XmlMigrator.java:692)
at com.atlassian.bamboo.migration.XmlMigrator.importXml(XmlMigrator.java:128)
at com.atlassian.bamboo.migration.XmlMigrator$$FastClassBySpringCGLIB$$b6578fc7.invoke(<generated>)
Cause
There are a number of possible causes:
- There is no export zip present at the path specified.
- The user running Bamboo does not have the appropriate permissions to access the path or export zip specified.
- Perhaps you altered the export zip but when you re-archived it you changed the structure. E.g. archived the parent directory and builds, configuration and db-export directories are no longer at the root of the archive.
After checking the above and confirming they are not a factor, it might be that your export is actually corrupted. Please raise a ticket with Atlassian Support at https://support.atlassian.com/ including a Support Zip and your Export Zip for analysis.