Remote Agent is loading on Bamboo UI never finishes

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Problem

When browsing to the Cog icon >> Agents, a Remote Agent is stuck, never added to the Agent list and the following message is shown on the UI: 

A remote agent is loading on 192.168.2.112 (192.168.2.112)

Diagnosis

There could be quite a number of underlying root causes. Be sure to check the $BAMBOO_AGENT_HOME/atlassian-bamboo-agent.log on the Remote Agent to see if there is more detail on why the Agent hasn't been able to fully establish a connection.

Resolution

Here's some generic steps you can follow to solve the most common types of issues that prevent the agent from connecting:

  1. Run through the Diagnosing Remote Agent Connectivity steps on the following guide: Troubleshooting Remote Agents
  2. Ensure that the Remote Agent is running on a server with latest supported JDK (not JRE) per our Supported Platforms
  3. If this doesn't help, please raise a ticket with us at https://support.atlassian.com/ and attach a Bamboo Support Zip as well as the Remote Agent log from $BAMBOO_AGENT_HOME/atlassian-bamboo-agent.log 

Last modified on Sep 23, 2019

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