Bitbucket Cloud Migration Assistant (BCMA) plugin stuck in the Running and Stopping state

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While using BCMA (Bitbucket Cloud Migration Assistant) plugin for Bitbucket Server to Cloud migration, the migration can freeze in the "Running" state.
Eventually, if you stop the migration, it may also get stuck in the "Stopping" state.

Here's an example screenshot of migration statuses:

Cause

The plugin can be in this behavior when the migration is interrupted by one or more of the following points of failures on the server side:

  • Storage limit
  • Server crash
  • Restarting the server before migration is complete

Solution

Re-installing the Bitbucket Cloud Migration Assistant (BCMA) plugin to reset all internal migration statuses.
Once re-installed, restart the migration process again.
(info) Please be informed that removing and re-installing the Bitbucket Cloud Migration Assistant (BCMA) plugin will not delete your migration plans as those are just stored data points in your database and no history will be lost.

How to re-install the BCMA plugin:

  1. Navigate to Bitbucket server Settings
  2. Under Add-Ons select Manage apps
  3. Locate the Bitbucket Cloud Migration Assistant add-on and click the drop-down menu
  4. Click Uninstall to remove the add-on
  5. Download and install the latest version of the Bitbucket Cloud Migration Assistant (BCMA) plugin.


Last modified on Nov 11, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.