Filtering for active repositories on the Repository Management page also displays archived ones in Bitbucket Data Center

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Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary


On the Advanced Repository Management page, filtering for only active repositories also lists archived repositories. However, this issue resolves itself after some time. This inconsistency is especially noticeable when the instance is newly set up, and the search indexing is being rebuilt from scratch.

Environment

7.21.x,8.9.x,8.19.x

Diagnosis

  1. Verify the Queue Size of the Search Indexed Events through the REST API.

    Curl
    curl -k -u <BITBUCKET_SYS_ADMIN:PASSWORD> <BITBUCKET_NODE_IP:7990>/rest/indexing/latest/status
    
    Output:
    
    {"queues":{"delay":0,"event":50000},"status":"INDEXING"}
  2. Check if the search indexes were recently deleted, as that could significantly load the indexing queue, causing archived repositories to appear under the active filter temporarily.

Cause


The Advanced Repository Management page is primarily served based on information from the search indexes. If the search indexes are down, the entire page won't load any information, as it is entirely dependent on search indexing data. 

Curl
<BITBUCKET_BASE_URL>/rest/search/latest/repository-management?start=0&limit=25&avatarSize=64&sortOrder=RECENT_ACTIVITY_DESC&archived=ACTIVE

When the search indexing queue is full due to the deletion of search indexes or reindexing of Search Indexes , or moving Search from one server to another, or if there have been very large pushes that keep the indexing queue busy, changes such as marking a repository from active to archived are saved in the Bitbucket database but these changes are queued to be updated and indexed on the search indexing server. 

Until this update occurs, the repository might still appear under the active filter, causing the inconsistency. By default, the delay should be minimal, only a few seconds, as the search server actively indexes all changes. This issue only arises when the search indexing queue is heavily loaded.

Solution

Wait for the search indexing to finish, after which the information on the Advanced Repository Management page should be accurate and correctly represent the status of the repositories.

Last modified on Sep 28, 2024

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