Unable to merge a pull request with the LDAP user account due to missing email address in Bitbucket Server.

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While trying to perform a Pull Request Merge with the LDAP user account, a pull request gets rejected with the following error "Your user account, XYZ, does not have an e-mail address. Merging a pull request records you as the author of the resulting merge commit, and this requires an e-mail address."

Environment

6.10.10

Cause

This issue generally occurs when an Email Id is not specified or configured for the LDAP user account and same user is trying to perform Pull Request Merge in Bitbucket Server. To perform the Pull Request Merge, the user should have an email address associated.
For the LDAP user, the email address needs to be added in the Active Directory with help of LDAP Admin (If user is not having direct access to Active Directory). Email address helps to notify users during complete pull request cycle like pull request creation, modified, declined, deleted or merged, etc. Also Email address helps to perform git operations like git clone, git push, branch creation through git, etc.


Solution

Adding an Email Id or Email address to the LDAP user account in the Active Directory, should resolve Pull Request Merge issue.

Last modified on Aug 9, 2022

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