When you click on the mirror or navigate to the Troubleshooting and Support Tools page of a mirror in Bitbucket Data Center, the page keeps showing "Loading add-on Mirror," and the actual content fails to display.

Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

In the Bitbucket Server administration panel a message is displayed saying "Loading add-on Mirror" indefinitely when performing one of these activities:

  • Trying to select which projects to mirror to a Bitbucket Smart Mirror:

  • Trying to access the Atlassian Troubleshooting and Support Tools for a Bitbucket Smart Mirror:

Environment:

The solution has been validated in Bitbucket Data Center 8.9.3 but may be applicable to other versions.

Diagnosis:

No errors will be logged in the atlassian-bitbucket.log of either the mirror or the upstream node, indicating that this is not a server-side issue. However, when you inspect the network request in the browser, the following error will be logged.

  • Issue 1:
    While loading projects on the mirror page, the main GET request to the /plugins/servlet/admin/mirror endpoint will show a status of "blocked:other," even though the related request in the Bitbucket mirror log will be marked as successful.


  • Issue 2:
    While loading projects on the mirror page, the main GET request to the /plugins/servlet/admin/mirror endpoint will show a status of "(failed)net::ERR_CONNECTION_REFUSED", and the related request in the Bitbucket mirror log won't be seen.

Cause 1:

The reverse proxy server is setting an HTTP response header that prevents the content rendered by the mirroring add-on from being displayed.

The user interface used to select which projects to synchronize to a Smart Mirror or to display the Atlassian Troubleshooting and Support Tools is embedded into the administration panel via an iframe. If the reverse proxy has been configured to send the X-Frame-Options header with the value SAMEORIGIN, the browser will not load any content embedded via iframes, and as a result the required user interface elements will not be displayed correctly.

For instance, Apache HTTP Server can be configured to behave in this way (i.e. set this header) with the following directive:

Header always append X-Frame-Options SAMEORIGIN

Cause 2:

The Bitbucket mirror isn’t accessible from the user's machine.


Resolution 1:

To resolve this problem, adjust the configuration of the load balancer so it no longer sets the X-Frame-Options header with SAMEORIGIN as its value.

Resolution 2:

Enable network connectivity from the user's machine to the Bitbucket mirror Base URL. After enabling the connection, verify it by accessing the Mirror URL from any browser.


Description

The Bitbucket Smart Mirror UI elements for configuring which projects to synchronize is not displayed and instead a message shows saying "Loading add-on Mirror" because the reverse proxy sends a header preventing this from working

ProductBitbucket Server
Last modified on Dec 23, 2024

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