Attachments Do Not Render in Some JIRA Issues
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When a user navigates to certain JIRA projects, the error below is displayed when trying to view attachments:
A similar error to the following appears in the JIRA logs after replicating the error:
[java.lang.Exception: com.atlassian.confluence.rpc.RemoteException: You're not allowed to view that page, or it does not exist.]
2015-06-02 16:31:21,965 TP-Processor14 WARN sysadmin 991x2485x1 1tdtyha 131.103.28.240,104.192.140.241 /secure/AjaxIssueAction!default.jspa [jira.issue.attachment.FileSystemAttachmentDirectoryAccessor] Unable to make thumbnail directory
Cause
Even though the attachments for that issue exist in the file system, the application does not have access to retrieve the information or create a thumbnail preview to de displayed in the issue.
Resolution
The owner/group of the attachment needs to be updated so that the application can retrieve the attachment.
Support can do this recursively for the attachments in JIRA Cloud by running the following:
chown -R js-jira:js-apps /data/jirastudio/jira/home/data/attachments/