Google Workspace sync results in the "Your userbase might be out of date" error

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

A previously working Google Workspace integration with Atlassian Cloud sync returns the "Your userbase might be out of date" error


Environment

This issue impacts Atlassian Cloud organizations with:

  • Google Workspace (formerly GSync) integration with an Atlassian Access subscription or
  • Google Workspace (formerly GSync) integration without Atlassian Access

Diagnosis

  • The error "Your userbase might be out of date" appears when attempting to sync with Google Workspace under the Identity Providers section, to find this:
  • You might also notice a mismatch between the number of verified domains in the following two areas of the Atlassian Cloud UI:
    • The Identity providers menu will show a lower domain count, because this section is being fetched from the verified domains inside of the Atlassian organization. You can find this section by:
    • But if you click on the Google Workspace Identity Provider settings, the count will be higher. The reason being, this is being fetched from the Google Workspace account directly. You can find this section by:
  • To identify the conflicting domain, compare your Google Workspace domains versus your Atlassian Organization verified domains.


Cause

A domain or domains were unverified from Google Workspace but not removed, causing a sync conflict between Atlassian Cloud and Google

Solution


Last modified on Aug 21, 2024

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