How to sync 'department' attribute to Managed Atlassian Accounts using Entra ID SCIM provisioning

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Managed Atlassian Accounts have different attributes such as Department, Full name, etc. This article seeks to explain how to sync the department attribute to those Managed Accounts

Environment

  • Atlassian Cloud
  • Atlassian Guard (formerly Access)
  • Atlassian Cloud Azure Enterprise Application
  • Entra ID (Azure AD)
  • SCIM integration 

Diagnosis

Entra ID accounts department value is not syncing to Atlassian account even if SCIM User Provisioning is configured.

Cause

SCIM User Provisioning configuration has not mapped the department attribute to sync to Atlassian.

Solution

  1. Login to your Azure Portal - https://portal.azure.com/#home
  2. Click on Enterprise Applications
  3. Look for the Atlassian Cloud application, open it
  4. Under the Manage section, click on Provisioning
  5. Under Manage provisioning, click on Edit attribute mappings
  6. Expand the Mappings section, click on Provision Azure Active Directory Users
  7. Under Attribute Mappings, click on Add New Mapping
  8. Map the attribute:


TypeFromAttribute Name
SourceEntra IDdepartment
TargetAtlassian Cloudurn:ietf:params:scim:schemas:extension:enterprise:2.0:User:department

Your new attribute should look something like this:

Click Save and let Entra ID process the new information. Entra ID will update all required users at the next provisioning cycle. Or you can use On-demand Provisioning to trigger provisioning for one or more users manually to observe the changes sync to Atlassian.


Last modified on Jul 10, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.